Website Analytics With Matomo: Prerequisites

Useful WebsitesThis post is part of the where I am taking a look at Matomo which bills itself as a Google Analytics alternative that protects your data and your customers’ privacy.

The prerequisites for installing the on-premise version of Matomo are quite straightforward:

  • Matomo can be run on any operating system such as Linux (Ubuntu, RedHat, CentOS, Raspberry Pi OS, etc.), Windows, macOS Server or FreeBSD.
  • A webserver such as Apache, Nginx, IIS, LiteSpeed, etc.
  • PHP version 7.2.5 or greater (the previous major vrsion of Matomo will run on PHP version 5.5.9 through to PHP 7x).
  • MySQL version 5.5 or greater or MariaDB
  • PHP extension pdo and pdo_mysql or the mysqli extension.
  • A mySQL/MariaDB database.
  • A mySQL/MariaDB user with permissions to create/alter tables in the database.

If you’re running a high traffic site, there are some resources available covering recommended setup.

Full requirements are available here.