Migrating to ClassicPress: Using Migration Plugin With Unsupported WordPress Version

ClassicPressThis post is part of a series on migrating to ClassicPress from WordPress.

ClassicPress provide a migration plugin which you can use to migrate from WordPress to ClassicPress. The developers working on ClassicPress are also keeping the plugin updated for new releases of WordPress, but will lag a little behind as they need to wait for WordPress to release the new version before they can update the migration plugin.

I’ve been doing testing on ClassicPress and this has also included testing the plugin. Sometimes I’ve wanted to upgrade from an version not supported by the plugin.

The easiest way, in my experience, to use the plugin on a new version of WordPress before it is officially supported, is to amend the plugin to change the value to which the $wp_version_max parameter is being set:

admin-page.php showing line 318

Changing the value from 5.0.2 to 5.0.3 will allow the migration plugin to be run against the latest version of WordPress.

Instead of updating the plugin, you can also add the following line to your theme’s functions.php:

add_filter( 'classicpress_ignore_wp_version', '__return_true' );

I’ve tended to go with updating the plugin code, rather than adding the code to my functions file as I prefer to only have code in my theme that is for the benefit of the theme itself.

What should we write about next?





Your Name (required) –
Your Email (required) –

Leave a Reply

Your email address will not be published. Required fields are marked *