Bad Building Blocks – Error generating report in Management Reporter

Microsoft Dynamics GPAs you may have noticed I have been doing a fair bit of work recently with Management Reporter and this has involved a number of upgrades from FRx which has meant I have used the Migration Wizard a number of times.

When I used it a few weeks ago (screenshots taken at the time but I haven’t had time to post it until now) everything went well. I was able to view the report definitions and check that everything looked okay. However, I ran into a problem when it came to generating a report. Any report. I received the following message:

Management Reporter - Bad or missing data was encountered while loading the report and its building blocks. Report generation has been cancelled.Management Reporter – Bad or missing data was encountered while loading the report and its building blocks. Report generation has been cancelled.

I checked the Windows Event Viewer and it has recorded the error as well, but the error message wasn’t that useful.

Windows Event Viewer

I selected one report as my test bed and checked everything over thoroughly looking for where the problem was thinking that the cause was something in the migration. Eventually, I fixed the problem.

How? Simply by restarting both of the Management Reporter processes. Other than the error when trying to run a report, there were no signs that there had been an issue with the services (they’d both reported starting okay), but there was obviously something wrong which was resolved by a restart.

What should we write about next?

Your Name (required) -
Your Email (required) -

4 thoughts on “Bad Building Blocks – Error generating report in Management Reporter

  1. Marc K says:

    I originally did a test conversion from FRx using the migration wizard shipped with Management Report 2.0. When I tried it again with Management Reporter 2012 RU5, there were a lot more problems (mostly with dimensions being blank on imported rows.) I ended up reinstalling Management Reporter 2.0 to do the actual conversion.

  2. Hilquias says:

    The same happened to me after migration.
    I only restart the MR client.

  3. Celia says:

    Thank you for this post, it resolved my problem

Leave a Reply

Your email address will not be published. Required fields are marked *